[GTALUG] Beginner Debian Question(s)

Blaise Alleyne email+libre at blaise.ca
Fri Jan 1 18:22:28 UTC 2016

On 30/12/15 04:22 PM, Peter King wrote:
> On Wed, Dec 30, 2015 at 03:15:58PM -0500, Blaise Alleyne wrote:
>> On 30/12/15 10:03 AM, Peter King wrote:
>>> Now to figure out how to get root, or at least sudo... odd, because
>>> while it tells me the default user "linaro" is not in the sudoers group,
>>> in /etc/group "linaro" *is* listed as belonging to the sudo group.  Hmmm.
>> Weird. So, if you run `groups` sudo is listed as one of the groups?
>> Is the sudo package installed? (`dpkg --list | grep sudo`) Weird that there'd be
>> a sudo group set up if the package wasn't installed.
> Got it.  There was a missing "%" in the sudoers file, so it wasn't seeing
> "sudo" as a group but as a user.  Fixed it, and now I have sudo working.

Ah, great, glad that worked.

> The last major hurdle is to try to connect to the internet, which is tricky
> because I only have wireless access here and the Roseapple Pi seems not to
> recognize my wireless dongle -- though again maybe I'm just clueless under
> Debian, since the dongle has a RealTek rtl8192 chip, and there are modules
> listed for that in /var/modules/: rtlwifi.ko, rtl8192c.ko, and rtl8192.cu.
> [...]

I'm not familiar with that particular wireless device, but from this page on the
Debian wiki, it looks like it requires non-free drivers, and thus the Debian
non-free repository. If you didn't specifically install those rtl files above
from a download from the non-free repository, but rather they were installed by
default, I'm imagine they're different drivers, not the non-free ones.

Anyways, seems like you might find an answer here:

Though, ThinkPenguin sells inexpensive wireless adapters that don't require
non-free drivers:






More information about the talk mailing list