umount refusing to unmount /dev/cdrom

Scott Elcomb Scott.Elcomb-iRg7kjdsKiH3fQ9qLvQP4Q at
Tue Jul 20 04:23:35 UTC 2004

> Okay, I'll ask the dumb questions first... my apologies if you've done
> this already.

Lol.  No apologies necessary - in a lot of ways, I'm still a newbie with
basic *nix.  Most of the time I've spent with linux in the past 2 years
has been focused more on perl than linux.  (The rest I'm learning as I
need it.)

> 1) have you done lsof to check for anything open on the mount point?
> i.e. are you sure everything (including the terminal you're in) isn't
> touching the cdrom?

I've never really used or needed lsof (at least not until now.)

> 2) have you tried eject /dev/cdrom ?
Tried it, and again got:
  eject: unable to eject, last error: Invalid argument

however this time the disk did eject.

Thanks, and will have to look into lsof a bit.  :)

Take care,
- Scott.


PGP Public Key:
1024D/98125E76 2004-03-21 Scott Elcomb (dL33T) <Scott.Elcomb-iRg7kjdsKiH3fQ9qLvQP4Q at>
-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 189 bytes
Desc: This is a digitally signed message part
URL: <>

More information about the Legacy mailing list