umount refusing to unmount /dev/cdrom

Martin Duclos tchitow-PkbjNfxxIARBDgjK7y7TUQ at
Tue Jul 20 13:56:35 UTC 2004

Hi Scott,

I've had the same problem myself. Take a look at lsof as suggested and "lsof 
| grep for /mnt/cdrom". I'm almost positive the result will tell you that 
fam is using it. fam is some kind of program that handles the graphics file 
brownsers and such... When there is a modification to a file or it's 
location or deleted, fam knows and notifies instantly all programs that may 
be viewing a file tree. This is useful (is it?) when you delete a file (or 
modify or move or...) so that the file browser gets updated instantly 
instead of having to refresh the view of files in the directory. Anyhow, I 
usually just kill the process and be done with it. My question is: is there 
a solution to this problem? Has anyone fixed it? I usually keep my system 
updated...Aside from that I haven't spent any time investigating that 
particular problem...



Hello all,

I have this annoying and ongoing issue on a FC1 machine; umount refuses
to unmount /dev/cdrom, and the drive refuseses to let go of a disk.

Sometimes I can eject a cd with Nautilus, sometimes not.

Currently, I'm using a lazy unmount and then waiting for 10 or 20
minutes.  After that I can eject the disk.  I've also tried waiting and
running umount / umount -f but neither seem to help.

Any advice would be most appreciated.

- Scott.

Quick specs:
PIII 600Mhz, unknown chipset/mb (the troublespot I'd imagine)
Fedora Core 1
HP9500 CDR/W
umount message: device or resource busy


PGP Public Key:
1024D/98125E76 2004-03-21 Scott Elcomb (dL33T) <Scott.Elcomb-iRg7kjdsKiH3fQ9qLvQP4Q at>
<< signature.asc >>

Take charge with a pop-up guard built on patented Microsoft® SmartScreen 
  Start enjoying all the benefits of MSN® Premium right now and get the 
first two months FREE*.

The Toronto Linux Users Group.      Meetings:
TLUG requests: Linux topics, No HTML, wrap text below 80 columns

More information about the Legacy mailing list