umount refusing to unmount /dev/cdrom

Kareem Shehata kareem-d+8TeBu5bOew5LPnMra/2Q at
Tue Jul 20 03:24:51 UTC 2004

On Mon, 2004-07-19 at 22:51, Scott Elcomb wrote:
> Hello all,
> I have this annoying and ongoing issue on a FC1 machine; umount refuses
> to unmount /dev/cdrom, and the drive refuseses to let go of a disk.
> Sometimes I can eject a cd with Nautilus, sometimes not.
> Currently, I'm using a lazy unmount and then waiting for 10 or 20
> minutes.  After that I can eject the disk.  I've also tried waiting and
> running umount / umount -f but neither seem to help.
> Any advice would be most appreciated.
> Thanks,
> - Scott.
> Quick specs:
> PIII 600Mhz, unknown chipset/mb (the troublespot I'd imagine)
> Fedora Core 1
> HP9500 CDR/W
> umount message: device or resource busy

Okay, I'll ask the dumb questions first... my apologies if you've done
this already.

1) have you done lsof to check for anything open on the mount point?
i.e. are you sure everything (including the terminal you're in) isn't
touching the cdrom?

2) have you tried eject /dev/cdrom ?


   kareem-d+8TeBu5bOew5LPnMra/2Q at   -    Kareem Shehata     -     416-766-4911     
      It is with logic that one proves; it is with intuition that
      one invents.
        -- Henri Poincare

The Toronto Linux Users Group.      Meetings:
TLUG requests: Linux topics, No HTML, wrap text below 80 columns

More information about the Legacy mailing list