Compile asks for ALSA

Marc Lanctot lanctot-yfeSBMgouQgsA/PxXw9srA at
Wed Jul 16 02:15:15 UTC 2008

Giles Orr wrote:

> ./configure stalls out with this error:
> ... [ lots of "checking for ... yes" snipped ]
> checking for pthread_create in -lpthread... yes
> checking for snd_mixer_open in -lasound... no
> configure: error: You must have ALSA Installed!
> Of course I have ALSA installed.  I have the package that provides the
> "alsamixer" binary but it's evidently not looking for that either.  I
> assume the reason I can't find alsa*-dev packages for Debian is
> because ALSA is now in the kernel.  I've installed kernel source to
> match my running kernel binary, but that was a stretch and didn't
> work.  Hints or work-arounds accepted!  If more information would be
> useful, please let me know.

I had to deal with this recently for a different reason... ah yes, now I 
remember.. I was building VICE from scratch. I seem to remember there 
being ALSA dev packages a while back.. anyway, what worked for me was to 
install the asound dev packages:

lanctot at gravid:trunk% apt-cache search asound | grep dev
lib64asound2-dev - ALSA library development files (64 bit)
libasound2-dev - ALSA library development files
libasound2-doc - ALSA library developer documentation
libalsa-ocaml-dev - OCaml bindings for the ALSA library
libecasound2.2-dev - development files for ecasound
libecasoundc2.2-dev - c binding files for ecasound (devel)
libkvutils2.2-dev - kvutils library required for ecasound - development
lanctot at gravid:trunk%

My guess is that asound is related to ALSA? Sorry that I can't give a 
better explanation but installing asound2-dev worked for me. (The 
package names might be slightly differ because I did this after a new 
Ubuntu install)


First they ignore you, then they laugh at you, then they fight you,
then you win.
   -- Mohandas Ghandi
The Toronto Linux Users Group.      Meetings:
TLUG requests: Linux topics, No HTML, wrap text below 80 columns

More information about the Legacy mailing list