route, ping, where's the net?

Lennart Sorensen lsorense-1wCw9BSqJbv44Nm34jS7GywD8/FfD2ys at
Fri Nov 4 22:16:11 UTC 2005

On Fri, Nov 04, 2005 at 02:10:31PM -0500, Peter King wrote:
> The answer to this has *got* to be simple, but I just can't see it.
> I have a Sun Ultra-1 running Gentoo-Sparc64. I can ping any address
> on the internet just fine. When I run ifconfig the ethernet cards are
> properly detected and given their correct values.
> But, when I run route, the system just sits there -- I don't get any
> kernel routing table.
> When I run netstat -nr, though, I do get a routing table... though not
> with netstat -r. Well, the only difference is DNS, right? But then I
> don't see why pinging domain names should work (and it does).
> If I try to add a default route like so:
>   #route add default gw
> it responds with a message that the file exists. (Huh?)
> This has *got* to be something low-level and obvious that I'm just not
> seeing. Suggestions? What should I try next? 

route command uses reverse dns lookups to display hostname/network
names.  route -n does not.  I suspect route -n works for you.  route
probably does too if you wait enough minutes for dns to timeout.

pinging by hostname on the otherhand does normal dns lookups (name to
ip) not reverser (ip to name).  To me this means you have a problem with
doing reverse dns lookups of some IPs, while forward lookup of domains
works fine.

Lennart Sorensen
The Toronto Linux Users Group.      Meetings:
TLUG requests: Linux topics, No HTML, wrap text below 80 columns

More information about the Legacy mailing list