route, ping, where's the net?

Peter plp-ysDPMY98cNQDDBjDh4tngg at
Fri Nov 4 19:18:54 UTC 2005

On Fri, 4 Nov 2005, Peter King wrote:

> The answer to this has *got* to be simple, but I just can't see it.
> I have a Sun Ultra-1 running Gentoo-Sparc64. I can ping any address
> on the internet just fine. When I run ifconfig the ethernet cards are
> properly detected and given their correct values.
> But, when I run route, the system just sits there -- I don't get any
> kernel routing table.
> When I run netstat -nr, though, I do get a routing table... though not
> with netstat -r. Well, the only difference is DNS, right? But then I
> don't see why pinging domain names should work (and it does).
> If I try to add a default route like so:
>  #route add default gw
> it responds with a message that the file exists. (Huh?)
> This has *got* to be something low-level and obvious that I'm just not
> seeing. Suggestions? What should I try next?

firewall ? /etc/host.conf ? other DNS issues ? (like, is the host 
running an unconfigured dns ?) Try /sbin/route in case there is another 
route in the path.

The Toronto Linux Users Group.      Meetings:
TLUG requests: Linux topics, No HTML, wrap text below 80 columns

More information about the Legacy mailing list