route, ping, where's the net?

Peter King peter.king-H217xnMUJC0sA/PxXw9srA at
Fri Nov 4 19:10:31 UTC 2005

The answer to this has *got* to be simple, but I just can't see it.

I have a Sun Ultra-1 running Gentoo-Sparc64. I can ping any address
on the internet just fine. When I run ifconfig the ethernet cards are
properly detected and given their correct values.

But, when I run route, the system just sits there -- I don't get any
kernel routing table.

When I run netstat -nr, though, I do get a routing table... though not
with netstat -r. Well, the only difference is DNS, right? But then I
don't see why pinging domain names should work (and it does).

If I try to add a default route like so:

  #route add default gw

it responds with a message that the file exists. (Huh?)

This has *got* to be something low-level and obvious that I'm just not
seeing. Suggestions? What should I try next? 

Peter King			 	peter.king-H217xnMUJC0sA/PxXw9srA at
Department of Philosophy
215 Huron Street
The University of Toronto		    (416)-978-4951 ofc
Toronto, ON  M5S 1A1

GPG keyID 0x7587EC42 (2B14 A355 46BC 2A16 D0BC  36F5 1FE6 D32A 7587 EC42)
gpg --keyserver --recv-keys 7587EC42
-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 189 bytes
Desc: Digital signature
URL: <>

More information about the Legacy mailing list