[GTALUG] Fan Control on Linux

Giles Orr gilesorr at gmail.com
Mon Jan 15 16:13:20 EST 2018

On 10 November 2017 at 20:31, Giles Orr <gilesorr at gmail.com> wrote:

> I have a very old laptop I'm trying to rehabilitate and use with Debian:
> it's got an AMD Turion chip and 1G of RAM.  Works fine.  But one annoying
> problem under Linux: the fan runs flat out all the time.  If the 'sensors'
> command is correct, the CPU has never gone above 35C, so the fan isn't
> running like that because of the heat.
> I also used this machine recently to run Darik's Boot And Nuke (aka
> "DBAN") on a hard drive: that's a Linux kernel, and the fan wasn't running
> full out.  Not sure what that proves, except that the fan doesn't have to
> run full out under a Linux kernel.
> I've installed "lm_sensors," I've installed "fancontrol", I've run
> 'lmsensors-detect' (which is 'sensors-detect' under Fedora and Ubuntu -
> I've tried three Linux OSes with essentially identical results).  I've run
> 'pwmconfig' which tells me "There are no pwm-capable sensor modules
> installed."  I've written a file into /etc/sensors.d/fan-speed-control.conf
> that said this:
>     chip "k8temp-pci-*"
>     set fan1_div 4
> (This last at the suggestion of ArchWiki, which says reducing the fan
> multiplier can make it accessible to Linux.)  But running 'sensors -s' to
> reload the config is greeted with "Error: File /etc/sensors.d/fan-speed-control.conf,
> line 2: Unknown feature name k8temp-pci-00c3: No such subfeature known."
> On an off-chance I tried "fan0_div" and "fan2_div" but same answer.  This
> has exhausted most of the mainstream remedies suggested by Google.  At this
> point I'm stumped: can anyone else suggest ways to get a handle on this fan?

The solution to this was hard to find but simpler than expected: add the
'noapic' option on the command line to the kernel at boot time, and
magically everything is working fine.  I did this after finding a reference
to that on a page for the particular HP laptop - it was a problem a decade
ago too.  According to a RedHat page, " APIC is the replacement for the old
PIC chip that, in the past, was embedded on motherboards and allowed the
configuration of interrupts for peripherals like soundcards, IDE
controllers, sharing/redirecting of interrupts. Disabling APIC removes the
ability to make use of IRQ sharing or device IRQ remapping."  Which is
great and I can see that it might relate to fans, but ... I don't really
get it.

gilesorr at gmail.com
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://gtalug.org/pipermail/talk/attachments/20180115/9c33758d/attachment.html>

More information about the talk mailing list