war story: busted SATA ports

D. Hugh Redelmeier hugh-pmF8o41NoarQT0dZR+AlfA at public.gmane.org
Thu Mar 6 18:07:47 UTC 2014

I have a MythTV server that stopped working.  It turned out that the BIOS 
POST (Power-On Self-Test) would not complete with any device plugged into 
a SATA port.  It would boot from a floppy (yeah, I have a floppy drive on 
the machine).

The motherboard is an ECS GF8200a 

Not new, but otherwise useful.

I found that a SATA host adapter plugged into the PCIe slot worked.  But I 
needed 4 ports.  So I bought a 4-port SATA PCIe x1 card: 
NewEgg was selling it for about $35 (including shipping).  The price has 
gone up in the last week.

After I installed the card but before I booted from the hard drive, I
booted a live Ubuntu 12.04.1 CD (via a USB drive) and did some fscks.
At first I used palimpsest, but I found that I preferred the logging
provided by good old fsck.  The good results made me feel safer to try
the first boot.  Oh yeah, I also figured out which disk was the boot
disk and rearraged the SATA cables so it would be the first found by
the BIOS (not necessary).

This card just worked.  The BIOS was able to boot from a drive on the
controller.  Ubuntu 12.04 LTS recognized the Marvell controller chip.
My system is now up and running.  I hope that it stays that way.

This solution was cheaper and easier than replacing the motherboard.
So far.

Odd factoid: this motherboard has never been able to boot a USB flash
memory with Ubuntu on it.  I've always had to use a CD or DVD; they
work even from an external drive connected by USB.  Being able to boot
a live CD is very useful when trying to diagnose machine problems.
The Toronto Linux Users Group.      Meetings: http://gtalug.org/
TLUG requests: Linux topics, No HTML, wrap text below 80 columns
How to UNSUBSCRIBE: http://gtalug.org/wiki/Mailing_lists

More information about the Legacy mailing list