Broadcom wireless on Debian Testing

JoeHill joehill-R6A+fiHC8nRWk0Htik3J/w at
Thu Jul 2 00:02:24 UTC 2009

Robert P. J. Day wrote: 

> On Wed, 1 Jul 2009, JoeHill wrote:
> > Robert P. J. Day wrote:  
> [referring to]
> > >   i just followed the same page for a BCM4318 wireless chip on a
> > > laptop running debian 5.01 and it worked fine.  
> >
> > The thing I'm not sure about is that the wiki seems to indicate that the
> > firmware installation is completely automated, ...  
>   for me, it was.  first, i made this change to /etc/apt/sources.list:
>    deb lenny main contrib non-free
> then ran:
>   # apt-get install b43-fwcutter wireless-tools
> at which point i was prompted to allow the installation of the actual
> firmware.  if memory serves, i simply said yes, away it went and when
> it was over, "lsmod" showed me numerous b43-related loaded modules.

Ack! This is where lack of experience comes in...forgot lsmod. When I run
lsmod, there is nothing in there about b43.

>   i still had no wireless until i invoked System -> Administration ->
> Network.  didn't *do* anything there, just opened it up and closed it
> and, suddenly, Network Manager could see the wireless networks in the
> area.  i'm not a debian guru so i'm guessing that doing that somehow
> ran a combo of iwconfig/ifconfig underneath.  in any event, wireless!
> no need to modprobe anything.  surprisingly painless.
>   this was all on a gateway mx7120, 64-bit AMD CPU, with BCM3418
> 802.11g wireless.

Does your notebook have a 'switch' for the wireless? This one has a sliding
toggle on the front that switches between a blue and a red indicator. I assume
blue is 'on', red is 'off'?

The Toronto Linux Users Group.      Meetings:
TLUG requests: Linux topics, No HTML, wrap text below 80 columns

More information about the Legacy mailing list