Broadcom wireless on Debian Testing

JoeHill joehill-R6A+fiHC8nRWk0Htik3J/w at
Wed Jul 1 15:31:06 UTC 2009

Robert P. J. Day wrote: 

> On Wed, 1 Jul 2009, JoeHill wrote:
> > I've got a notebook here with built in Broadcom wireless, and before
> > I mess this up too much I though I would ask for some tips in
> > getting this working.
> >
> > I did lspci and got the model like so:
> >
> > Network controller: Broadcom Corporation BCM4328 802.11a/b/g/n (rev 03)
> >
> > I found this article:
> >
> >
> >
> > which seemed to indicate that this was going to be a pretty trivial
> > process. Installing the b43-fwcutter and wireless-tools went off
> > without error and the firmware was extracted, but so far I've got no
> > wireless.
> >
> > I followed the suggested troubleshooting steps, excluding manual
> > installation of the firmware, no answers.  
>   i just followed the same page for a BCM4318 wireless chip on a
> laptop running debian 5.01 and it worked fine.

The thing I'm not sure about is that the wiki seems to indicate that the
firmware installation is completely automated, but then I see things explaining
when you need to use the b43 fw, and when you need to use the b43legacy fw. Is
is automatically detected and loaded? I tried entering both 'modprobe b43' and
'modprobe b43legacy', but still no go.


The Toronto Linux Users Group.      Meetings:
TLUG requests: Linux topics, No HTML, wrap text below 80 columns

More information about the Legacy mailing list