can't remove a broken package in Ubuntu

Madison Kelly linux-5ZoueyuiTZhBDgjK7y7TUQ at
Fri Dec 5 15:59:54 UTC 2008

Lennart Sorensen wrote:
> On Thu, Dec 04, 2008 at 01:46:07PM -0500, Lennart Sorensen wrote:
>> On Thu, Dec 04, 2008 at 12:51:31PM -0500, Madison Kelly wrote:
>>>   I installed a couple .deb packages trying to get my Brother QL-550 
>>> label printer working (and failing). Now I have been unable to remove 
>>> the package ql550cupswrapper... I keep getting the error:
>>> -=-=-=-=-=-=-=-=-=-=-
>>> # apt-get remove ql550cupswrapper -f
>>> Reading package lists... Done
>>> Building dependency tree
>>> Reading state information... Done
>>> The following packages will be REMOVED:
>>>   ql550cupswrapper
>>> 0 upgraded, 0 newly installed, 1 to remove and 45 not upgraded.
>>> 1 not fully installed or removed.
>>> After this operation, 0B of additional disk space will be used.
>>> Do you want to continue [Y/n]? y
>>> (Reading database ... 138584 files and directories currently installed.)
>>> Removing ql550cupswrapper ...
>>> /var/lib/dpkg/info/ql550cupswrapper.postrm: 4: /etc/init.d/cupsys: not found
>>> dpkg: error processing ql550cupswrapper (--remove):
>>>  subprocess post-removal script returned error exit status 127
>>> Errors were encountered while processing:
>>>  ql550cupswrapper
>>> E: Sub-process /usr/bin/dpkg returned an error code (1)
>>> -=-=-=-=-=-=-=-=-=-=-
>>> Any idea what I can do to force the removal of this package?
>>> I've tried fixing broken packages, but no luck. This is particularly 
>>> troublesome as I can't install new packages or update the system.
>> Edit /var/lib/dpkg/info/ql550cupswrapper.postrm, and on line 2 put 
>> 'exit 0'.
>> It means it won't do whatever it has to do, but in this case it appears
>> you MUST have cupsys installed, to remove this package.  Making the
>> postrm script do nothing will let you at least remove the package,
>> although it may not clean up perfectly.
> Or you could add '||true' to the end of line 4 to make it ignore that
> error and do the rest of the script.

Thanks, Lennart,

   I symlink'ed cupsys to cups, and it worked fine. I didn't think to 
look for the .postrm file, doh!

The Toronto Linux Users Group.      Meetings:
TLUG requests: Linux topics, No HTML, wrap text below 80 columns

More information about the Legacy mailing list